Release:GIMP 2.8.12

From GIMP Developer Wiki
Jump to: navigation, search

General release

Here goes anything we want to be checked or tested before a release goes out. This is a not-build-specific section.

List of blocker and critical bugs with milestone 2.8

List of bugs fixed in version 2.8 since last release

Dependencies

  • Make sure poppler-data is installed. Otherwise pdf-import for Asian and Cyrillic characters won't work. See bug 733525. poppler-data is not currently detected by the configure script, therefore had been forgotten in some previous releases.
  • Make GIMP require a more recent gettext: do not try and regenerate the localization files, unless you have gettext 0.19 or over. Older version will "forget" most Script-fu localized strings and you will end up with incomplete localization.

Testing

From the list of fixed bugs since last release finally test at least the blocker and critical bugs.

Windows release

Dependencies

Please list down here the dependencies bundled in the build, with their version, their configuration (which options or features are included), and any patch applied.

Testing

Make sure the conf.d configuration bug is fixed.

OSX release

Dependencies

See the JHBuild module configuration for the OS X build.

Testing

Testing of Sven's fixes to the OS X build 20.-22.7.2014: done