Difference between revisions of "Users:Tips"

From GIMP Developer Wiki
Jump to: navigation, search
m (Quickly selecting the layer's alpha)
m (Hiding all the dialogs)
Line 4: Line 4:
  
 
=== Hiding all the dialogs ===
 
=== Hiding all the dialogs ===
In order to hide all the dialogs and leave only the image window visible, press the '''Tab''' key. To show all the dialogs again, press the '''Tab'' key again.
+
In order to hide all the dialogs and leave only the image window visible, press the '''Tab''' key. To show all the dialogs again, press the '''Tab''' key again.
  
 
=== Quickly selecting the layer's alpha ===
 
=== Quickly selecting the layer's alpha ===

Revision as of 23:42, 23 August 2010

This page contains a list of GIMP tips which are rarely known and/or extremely useful. Some of these if are not already included, then should be included in the gimp startup tips. This page is used to collect these tips both for users and for developers to see what should possibly be added to gimp-tips.

Do you have more tips that you think that should be included? Contact us (See the Main_Page for details) and we'll add them.

Hiding all the dialogs

In order to hide all the dialogs and leave only the image window visible, press the Tab key. To show all the dialogs again, press the Tab key again.

Quickly selecting the layer's alpha

Since 2.7.1

Inside the layer's dialog, you can alt+click on a layer to bring it's alpha to selection. By using modifiers in the same way as in the other selections, you can add (Shift), subtract (Ctrl) or intersect (Ctrl+Shift) the alpha of the layer with the existing selection.

A new image from any drawable

Sometimes, you have a drawable (layer/mask/channel) that you want to create a new image from (to work on it alone or for other reasons). No problem - drag the drawable from it's dialog (the layers/channels dialog) and drop it on the toolbox - this will create a new image containing only that drawable, without removing it from the original image.

Blending/Fading an action

Let's say you want to create a soft glow effect for a specific drawable (ignore the fact that such a filter exists :P). The simple way to do this, would be to duplicate the layer, blur it, put it on lighten only mode and then merge both layers together. This is where the Fade option comes to the rescue! Instead of creating a duplicate of the layer, blur it directly and then go to Edit->Fade. A dialog will pop up and allow you to blend the state of the drawable before and after the last action - simply select lighten only mode and adjust the opacity to fine control the amount of glow.

The fade option can save almost all the cases in which you would create another layer just for one operation - it's very handy!

Faking custom shaped guides

Let's say you want to have a guide which is not a straight line but instead it has a custom shape. No problem - draw this shape using the paths tool (or even better - you can import the shape if it's saved as an SVG file, by clicking the import button in the paths dialog). Then make sure it's the active path (by clicking on it in the paths dialog) and go to View->Snap to Active Path. For some reason, people underestimate how powerful this feature is, and rarely use it :P

FG/BG colors in color buttons

Many of GIMP's plugins/tools require you to choose a color using a color button. In most cases, right clicking the color button will show a menu from which you can pick one of "Foreground Color", "Background Color", "Black", "White".

Working on a single channel

If you only want to modify a specific channel of your drawable (usually one of Red, Green and Blue), go to the channels dialog/tab. You'll see the list of the available channels - by default they should all be selected. Deselecting a channel can be done by clicking on it - then any action you'll do won't affect the channels which are disabled.

Reversing the order of animation frames

This happens a lot - you created an animation (each frame represents one layer) and then you discovered the frames are in the reversed order... Don't worry - GIMP can fix this for you - go to Layer->Stack->Reverse Layer Order. Surprisingly, many people don't even know this feature exists.