Release:2.10 changelog

From GIMP Developer Wiki
Revision as of 23:35, 23 December 2015 by Prokoudine (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

This page should aid documentation authors in updating the user manual for the upcoming 2.10 release.

Core

GIMP 2.10 uses GEGL image processing library for all operations.

  • new Image -> Precision submenu
  • switch between perceptual gamma and linear light
  • optional dithering during conversions between precision modes
  • optional experimental hardware-accelerated rendering and processing via OpenCL (see Edit -> Preferences -> System Resources)

Layers, Paths, Channels

  • Add content locking to items to prevent them from being edited
  • Add position locking to items to prevent them from being translated
  • Overlay mode is not identical to Soft Light mode anymore and finally relies on a widely used formula from both PDF specification, as well as W3C’s “Compositing and Blending Level 1” spec
  • Add LCH layer modes: Hue, Chroma, Color, and Lightness. See http://ninedegreesbelow.com/photography/gimp-lch-blend-modes.html for details

Tools

General Changes

  • Add undo/redo to many tools using the normal shortcuts (FIXME: provide a more detailed explanation)
  • Allow tool dialogs to be embedded on the canvas genrically

New Tool: Unified Transform

Combines rotation, scaling, skewing, and adjusting perspective in a single tool.

New Tool: Warp Transform

Replaces the old iWarp plugin and provides its features in a tool that works directly on images, without a preview window.

New Tool: Handle Transform

Apply scaling, rotating, and perspective correction using handles placed on the canvas.

New Tool: N-Point Deformation

A new way to bend objects while preserving a natural look.

New Tool: Seamless Clone

Simplifies merging one image into another by adjusting brightness and colors of the pasted image to match the look of the image it is pasted to.

New Tool: MyPaint Brush

Use MyPaint brushes for painting.

Updated Tool: Blend

The tool is now more interactive. After drawing with the tool to define the beginning and the end of the gradient fill, you can adjust start/end positions and change colors.

Updated Tool: Align

Now features vertical and horizontal fill modes.

Updated Tool: Foreground Select

Can finally make subpixel selections in complex cases such as strays of hair on textured background. Two new masking methods for that were added, and the user interface was updated accordingly.

Updated Tool: Text

  • Port text rendering to GEGL
  • Use HarfBuzz to inspect fonts for creating an example string

Updated Tool: Fuzzy Select / Select by Color

  • new Draw mask option to display future selection area with a magenta fill

Plugins

  • On-canvas preview for all filters that use a GEGL operation
  • Allow plug-ins to access image data at full bit depth
  • Add a compat mode so unported plug-ins always get 8-bit data
  • New plugins/filters: Mono Mixer, Color to Gray, Sepia, Color Temperature, Exposure (FIXME: CHECK the full list)
  • Removed plugins: Maximum RGB, iWarp (FIXME: CHECK the full list)
  • Decompose plugin supports LCH now (FIXME: CHECK the full list of supported color models)

Color Management

  • Implement all color management in the core (not as a plugin)
  • Support ICC v4 color profiles
  • Make both RGB and Greyscale images color managed
  • Reimplement assigning, converting, and discarding ICC profiles
  • Display ICC profiles metadata in various parts of UI (color space conversion, selection of a profile from the disk etc.)
  • Add preferred RGB and GREY color profiles settings to the Preferences dialog to make them quickly accessible in profile selection combo boxes

Metadata

  • Implement metadata handling in the core
  • Add Image -> Image Metadata dialog for viewing Exif, IPTC, and XMP info
  • PNG, JPEG, and TIFF exporters now have Save Exif, Save IPTC, and Save XMP options in the Advanced group of settings

File Format Support

  • 16/32bit per color channel support for PNG, TIFF, PSD (no more stripping data)
  • 16/32/64bit per color channel support for FITS (no more stripping data)
  • OpenEXR loading and exporting
  • Add zlib compression to XCF loading/saving

Dockable Dialogs

  • Add an automatic palette of recently used colors
  • Add MyPaint Brushes dialog

Digital Painting

  • Canvas rotation and flipping have been added to facilitate users who need to paint from a different angle or check composition for errors.
  • Optional locking of brush size to zoom.
  • All tools that use GIMP’s brush engine have Hardness and Force sliders now

Configurability

  • Icon Themes can be added, selected, and removed now (Edit -> Preferences -> Interface -> Icon Theme)
  • New Image Windows -> Snapping page in the Preferences dialog allows choosing default snapping settings for both normal and fullscreen modes
  • Snapping distance setting has move to the Image Windows -> Snapping page
  • Selection of visible tools in the toolbox has moved to the Interface -> Toolbox page

General UI changes

  • Allow zooming to the selection
  • Make the image tab position configurable in single window mode
  • Add more format string options for the image title (FIXME: prepare the full list of new options)
  • Simplify and reduce the actions that modify paint tool behavior (FIXME: provide a more detailed explanation)
  • Allow selecting colors from an image's colormap