Hacking:Eclipse

From GIMP Developer Wiki
Revision as of 18:38, 9 April 2014 by Scl (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

This page will teach you how to set Eclipse IDE to work on the latest source of GIMP from git. The following steps describe the process for Eclipse 4.3 'Kepler'. _TOC_

About Eclipse

Why use Eclipse to work on Babl, GEGL and GIMP?

TODO

Why not to use Netbeans to work on GIMP?

TODO

Preparations

Prepare the build environment

Get Eclipse

In order to work with Eclipse on Babl, GEGL and GIMP, you will have to install the CDT plugin for Eclipse (or simply download Eclipse IDE for C/C++ Developers).

Configure Eclipse to work on Babl, GEGL and GIMP

Working with Eclipse

Code

Build

Install

Miscellanous

Problems and solutions